歡迎光臨, 訪客. 請先 登入註冊一個帳號.
六月 13, 2024, 02:54:14 上午
19595 文章 在 3865 主題 由 4580 會員
最新註冊會員: aa123aa1
  列出文章
頁: 1 ... 33 34 [35]
511  支援 / 安裝與設定 / 0.32升級1.0~我又碰壁了 於: 四月 07, 2005, 02:42:34 上午
依照先前Beta版的步驟作
前四個步驟都順利完成了
也將wizard.php宜除完畢
接著,按下前往管理介面按鈕之後
出現了以下錯欲訊息
可以請Mark前輩或其他看得懂錯誤發生在哪的高手們指點一下嗎?

程式碼:
Exception message: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/fotidvt/public_html/plog/config/config.properties.php:20)
Error code: 2
-- Backtrace --
/home/fotidvt/public_html/plog/class/net/http/session/sessionmanager.class.php(37): session_start
/home/fotidvt/public_html/plog/admin.php(25): sessionmanager.init

Exception message: Cannot modify header information - headers already sent by (output started at /home/fotidvt/public_html/plog/config/config.properties.php:20)
Error code: 2
-- Backtrace --
/home/fotidvt/public_html/plog/class/view/view.class.php(172): header
/home/fotidvt/public_html/plog/class/view/view.class.php(308): admindashboardview.sendcontenttype
/home/fotidvt/public_html/plog/class/view/admin/admindashboardview.class.php(92): view.render
/home/fotidvt/public_html/plog/class/controller/controller.class.php(325): admindashboardview.render
/home/fotidvt/public_html/plog/admin.php(36): admincontroller.process
512  建議 / 發表與交流 / 「老貓學出版]升級成功&請大家幫忙 於: 四月 07, 2005, 02:17:53 上午
老貓前輩

這個問題我在0.32版修改summary三欄式模版時有碰過
後來的試了好久才勉強找到算是解決方法的方法
我曾經PO在官方論壇的templates版
http://forums.lifetype.net/viewtopic.php?t=1359&highlight=summary
給你參考,不知道有沒有用罷了
513  支援 / 使用與操作 / 也是亂碼的問題? 於: 四月 05, 2005, 01:23:20 上午
因年月日程式碼的大小寫分別代表不同的表達方式
在中文語系中又會因為空白字元的問題使得亂碼產生
我在0.32版就曾經用過兩種不同方法
第一就是不辭千辛萬苦的一個一個模版慢慢改
除了將小寫換成大寫之外,年月日的間隔也須加多幾個空白字元
有幾個模版原始的年月日間隔即使換了大寫,還會出現亂碼
加了空白字元拉長間隔就不會了

但是,我發現:人還是懶惰的
所以我用了算是畢其功於一役的作法
就是直接將中文語系檔中的年月日改成跟英語語系檔一樣
也就是不翻譯年月日的部分
這樣就不需要改所有的模版了 吐舌頭
只是不知道這一招在1.0管不管用
514  站務 / 站務建議 / 對pLog 中文開發論壇「時間」之建議 於: 四月 01, 2005, 09:43:23 下午
剛剛看了一下,他4月1號才註冊

就不要跟他口水了~
515  開發 / 模版設計 / 正式版沒有把所有模版包進去 於: 四月 01, 2005, 09:10:16 下午
我可以直接使用測試版包好的模版包嗎?
應該沒差吧?
我很懶得一個個檔案下載囉
 吐舌頭
516  站務 / 站務建議 / 對pLog 中文開發論壇「時間」之建議 於: 四月 01, 2005, 08:41:23 下午
就是啊~如果這麼執意要改
那微軟也要改啊~他也是用「台北」
政治真是個令人討厭的東西
517  測試 / LifeType 1.0 測試 / Re: 今天3月31日 於: 三月 31, 2005, 05:43:30 下午
引用自: tomex_ou
明天4/1就是出plog 1.0正式版的日子
好期待呀...

雖然已大概知道其長相,
但就像一個關心的產品要正式上審
總是會寄予厚望的...

開發團隊真的是辛苦了...
加油!!

有個小疑問,全球O時差嗎?
要不然我們要多等一天耶
518  支援 / 使用與操作 / 關於多使用者PLOG所產生的UID 於: 三月 30, 2005, 12:44:30 下午
我在我的plog(0.32版)裡刪掉一個使用者
再重新新增一個使用者
結果UID變成不連續
假設我第一次新增的使用者的UID是10
刪掉之後重新新增UID卻是11

是因為資料庫的關係嗎?
我在資料庫裡也把USER 10的相關資料欄位都刪除了

可是新增後還是不連續?
 why?疑惑
519  開發 / 外掛程式 / [問題][求助]問一下...有沒有這樣的外掛或是.. 於: 三月 22, 2005, 02:26:13 下午
引用自: geminititan

我試著修改過了...但還是沒有辦法....重新啟動 apache 也作過了!!!
這是我的檔案幫我看看好嗎??
http://163.32.69.74/~swap/htaccess.txt
感謝回答!!!  微笑


那一行指令應該寫成:
 
程式碼:
<IfModule mod_dir.c>
        DirectoryIndex summary.php index.html index.php
</IfModule>


另外.htaccess不是純文字檔吧?
520  支援 / 安裝與設定 / Re: 【問題】成功的升級了,但遇到怪狀況 於: 三月 17, 2005, 12:17:44 上午
引用自: markwu

2. 我比較好奇是你說重裝,然後用一個 new 的 folder,請問你是新安裝的嗎?所以 DB也是不同的了?你是說 summary 會有文章混在一起?

我用老貓大大說得零風險方法,就是將原有的DD複製一個替身成DB2
然後把/config的DB指向DB2
等於就是複製一個現在正在線上的替身來測試升級的問題
所以我的疑問是既然DB2跟DB的資料是一樣的,那升級後
應該在summary也會有已經存在的文章才對
怎會是空白一片?
引用自: markwu
3. 不,不只!例如 /gallery 你當然要留,要不然所以檔案中心檔案都不見了。我建議你先全部備份,只留下 /gallery, /templates, /config。 template 中的模版,如果 1.0 已經有相對應且 porting 的模版,請用新的模版取代。這樣去安裝應該沒問題。多人的 pLog 的升級一定比單人的複雜一些些,因為比較多東西考慮。建議先在測試機器上實驗成功再進行 production 的升級。不要一下就作了,那後悔會來不及。(應該沒那麼嚴重啦) :D

我居然沒考慮到還有檔案中心檔案 目瞪口呆
感謝Mark的提醒
521  支援 / 安裝與設定 / 【問題】成功的升級了,但遇到怪狀況 於: 三月 16, 2005, 11:05:49 下午
用老貓大大的零風險方法更新到1.0的0316版成功了
因為我當初是直接就裝在http://www.myblog.com/底下
所以新增了一個new的資料夾
用http://www.myblog.com/new/來測試
該改的url路徑也都改了
但summary中間的最新文章空白一片
旁邊的最多迴響文章、最新網誌的連結也是連回舊路徑
我本來以為是因為我有很多不同的使用者更換模版
我也沒有一個個幫他們換回預設模版測試
所以才會有這個問題,到更新後的後台去改全域設定時候發現
模版選項中有我原來有的那些已經安裝的模版了
但1.0 beta的templates可沒那麼多模版吧^o)
然後我就把模版放置的路徑./templates改成/new/templates
結果整個就當掉了連summary都出現一堆Smarty的錯誤代碼
所以全部砍了,想重新來過
我的疑問是:
1.為何為出現舊版plog的模版呢?因為1.0的templets裡只有最基本的那幾個模版
2.我再次嘗試的話一定得要先安裝完整的舊版,再全部砍掉只留config檔再上傳1.0新版嗎?(Wiki上如是說,還是我誤解了?)
522  測試 / LifeType 1.0 測試 / pLog 1.0 Beta Rev 1858 公開測試站台 於: 二月 04, 2005, 03:27:41 下午
Mark 大大
管理介面的templates應該會有最後的完成版吧?
有幾個頁面很陽春看起來像error messege
感覺上新的介面清爽多了
另外,在0.3X版本發表文章時,如果出現tag的符號:<或>
會出現「發表文章出現錯誤」
因為文章有>_<" 的表情
這個問題好像也修正了,真是太好了!
不過文章類別好像變成要點選才有作用
忘了選會出現「發表文章出現錯誤」,可以預設在General嗎?
523  支援 / 使用與操作 / 有關於"您的網誌伺服器與您所在地的時間 於: 二月 03, 2005, 03:51:47 下午
引用自: markwu
Hi helpers:

這應該是一個 Bug .

你用的是 0.32 嗎?我再猜 1.0 這個 bug 還在?我查查看。

Mark


我之前也碰過這個問題
問Oscar,他說1.0會修正這個問題
I am not good at programming.
所以要Mark大大幫忙檢查囉
有你們的努力讓我們一般使用者能安心使用 吐舌頭
524  開發 / 模版設計 / Re: 有沒有plog修改模版的教學呢? 於: 一月 21, 2005, 09:32:59 下午
引用自: Duncan
現在我只會修改css
不知道要怎麼去改banner之類的東西
請問一下有沒有完整的教學呢?~


你所謂的修改是指「換上」自己的banner還是「製作」新的banner
如果只是更換,那就只要改CSS的部分就好了
找到控制banner的id or class 把路徑換一下就好嚕
通常CSS都會把id or class的名字取做banner或是head
應該不難找 眨眼睛
525  建議 / 要求與建議 / Re: 1.0要四五月份才RELEASE, 太恐怖了 於: 一月 14, 2005, 05:32:05 下午
引用自: 24Hrz.net
引用自: 小坚
不是嗎?

官方網站的更新速度奇慢, 不得不讓我懷疑他們的開發熱情.


不要這樣吧,他們也有他們要做的東西,他們也要上班,休息,
要是好東西,等多久也沒問題哦~~


就是說呀~況且人家Oscar又沒收錢營利
我們要心存感激 天使
頁: 1 ... 33 34 [35]