歡迎光臨, 訪客. 請先 登入註冊一個帳號.
七月 13, 2020, 10:15:48 下午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  支援  |  安裝與設定  |  ShadedGrey找不到commentform.template?? « 上篇主題 下篇主題 »
頁: [1]
作者 主題: ShadedGrey找不到commentform.template??  (閱讀 6656 次)
yuchin
新手見習
*
文章: 23


檢視個人資料
« 於: 三月 24, 2008, 07:06:54 下午 »

今天想加入預設回響的主題時,發現找不到commentform.template
但看postandcomments.template裡卻是標示
程式碼:
{if $blogsettings->getValue("comments_enabled") && $post->getCommentsEnabled()==1}
<div id="respond">&nbsp;</div>
{include file="$blogtemplate/commentform.template"}
{/if}

那他是怎麼顯示回響的呢?  commentform.template該檔案又不存在??
請問如果要改回響的預設主題?該去哪裡改呢?
已記錄
hlps9999
版主
資深會員
*****
文章: 288



檢視個人資料 個人網站
« 回覆文章 #1 於: 三月 24, 2008, 10:07:02 下午 »

若你的模板裡有這個commentform.template,LifeType就會去讀取你這個模板的commentform。

若沒有,系統就會去讀取 /templates/default/comment.template 這個公用模板

印象中,這樣的設計是為了減少模板檔案的讀取數量,而且若要修改,管理員只要去修改這個公用模板即可。
已記錄
yuchin
新手見習
*
文章: 23


檢視個人資料
« 回覆文章 #2 於: 三月 25, 2008, 07:23:18 上午 »

是把公用模板的commentform.template
程式碼:
<div><label for="commentTopic">{$locale->pr("comment_topic")}</label><input type="text" name="commentTopic" id="commentTopic" value="{$topic}" /></div>
改成

程式碼:
<div><label for="commentTopic">{$locale->pr("comment_topic")}</label><input type="text" name="commentTopic" id="commentTopic" value="Re:{$post->getTopic()" /></div>

但這個方法雖然有成功,但第二次瀏覽該篇文章時
卻會出現

標題<input type="text" name="commentTopic" id="commentTopic" value="Re:
Fatal error: Call to a member function getTopic() on a non-object in D:\xampp\htdocs\blog\tmp\1\%%3F^3F2^3F2BCD9C%%commentform.template.inc on line 16

再來就一直是那個錯誤了?Why?
已記錄
yuchin
新手見習
*
文章: 23


檢視個人資料
« 回覆文章 #3 於: 三月 28, 2008, 04:58:59 下午 »

請問有人遇過同樣的問題嗎? 嚎啕大哭
已記錄
yuchin
新手見習
*
文章: 23


檢視個人資料
« 回覆文章 #4 於: 三月 30, 2008, 04:58:47 下午 »

後來我用一個治標不治本的方式暫時解決了!!
不過如果有更好的解決方式也請提出來一起討論

我的解決方法
已記錄
頁: [1]
LifeType 中文開發論壇  |  支援  |  安裝與設定  |  ShadedGrey找不到commentform.template?? « 上篇主題 下篇主題 »
    前往: