歡迎光臨, 訪客. 請先 登入註冊一個帳號.
二月 21, 2024, 06:54:41 下午
19595 文章 在 3865 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  支援  |  安裝與設定  |  [發問]簡潔網址設定成功但主頁連不到(已解決 « 上篇主題 下篇主題 »
頁: [1]
作者 主題: [發問]簡潔網址設定成功但主頁連不到(已解決  (閱讀 17022 次)
oc
LifeType 中文發展團隊
一般會員
*****
文章: 115


檢視個人資料 個人網站
« 於: 四月 10, 2005, 04:13:31 下午 »

昨晚設好了簡潔網址,主要就是修改pLog安裝的根目錄裡內建的.htaccess檔,把這三行:

     ErrorDocument 401 /plog/error.php
    ErrorDocument 403 /plog/error.php
    ErrorDocument 404 /plog/error.php

改為我實際的安裝路徑:

     ErrorDocument 401 /blog/error.php
    ErrorDocument 403 /blog/error.php
    ErrorDocument 404 /blog/error.php

然後到後台管理面版→全部站台管控→網址設定裡面,選擇「讓搜尋引擎易於搜尋的簡潔網址」,再按更新就成了。

這樣所有的文章連接、分類、引用等通通變成短網址了,像這樣:

http://b-oo-k.net/blog/post/1/165

我唯一的困惑是,首頁的網址(http://b-oo-k.net/blog/1 )卻無效,會產生「HTTP 404 - 找不到檔案」的錯誤。其他的連結都沒問題,只有首頁找不到,這是什麼道理呢? 困擾啊。:-(
已記錄

lss
我不是被~拉~~出來的,不要叫我大大!
總版主
超級會員
*****
文章: 1511



檢視個人資料 個人網站
« 回覆文章 #1 於: 四月 10, 2005, 11:22:33 下午 »

hi 老貓兄:

我用 FireFox 看到的訊息是:
引用
Parse error: parse error, unexpected T_LNUMBER in /home/booknet/public_html/blog/error.php on line 32

我用的版本,這個檔還沒修改過,第32行是個空白行。
也許 error.php 這個檔案有問題,試試重新上傳這個檔案也許有幫助。
已記錄

沒找過 常見問題集或不知道 如何在 LifeType 中文開發論壇發問的人,恕不回答問題
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #2 於: 四月 11, 2005, 07:49:12 上午 »

引用自: 老貓
昨晚設好了簡潔網址,主要就是修改pLog安裝的根目錄裡內建的.htaccess檔,把這三行:

     ErrorDocument 401 /plog/error.php
    ErrorDocument 403 /plog/error.php
    ErrorDocument 404 /plog/error.php

改為我實際的安裝路徑:

     ErrorDocument 401 /blog/error.php
    ErrorDocument 403 /blog/error.php
    ErrorDocument 404 /blog/error.php


另外最上面還有一行 RewriteBase /plog/ ,你有改成  RewriteBase /blog/ 嗎?
已記錄

lss
我不是被~拉~~出來的,不要叫我大大!
總版主
超級會員
*****
文章: 1511



檢視個人資料 個人網站
« 回覆文章 #3 於: 四月 11, 2005, 08:41:22 上午 »

引用自: markwu

另外最上面還有一行 RewriteBase /plog/ ,你有改成  RewriteBase /blog/ 嗎?

hi mark:
請問一下, RewriteBase 設定應該在簡潔網址模式下是用不到的吧!?我稍微看過原始碼,Oscar 為了保持與0.32的相容,仍舊用0.32的方式處理簡潔網址模式,我以為這個設定值只有 mod_rewirte 模式跟自訂網址模式才有用到。
勞你指導一下。
已記錄

沒找過 常見問題集或不知道 如何在 LifeType 中文開發論壇發問的人,恕不回答問題
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #4 於: 四月 11, 2005, 08:56:18 上午 »

引用自: lss
引用自: markwu

另外最上面還有一行 RewriteBase /plog/ ,你有改成  RewriteBase /blog/ 嗎?

hi mark:
請問一下, RewriteBase 設定應該在簡潔網址模式下是用不到的吧!?我稍微看過原始碼,Oscar 為了保持與0.32的相容,仍舊用0.32的方式處理簡潔網址模式,我以為這個設定值只有 mod_rewirte 模式跟自訂網址模式才有用到。
勞你指導一下


勞你指導一下?你賣阿ㄋㄟ共啦,我會折福的。這地方我還需要你指導呢?呵呵!我只是把我想的到需要修改的地方 post 上來。

我剛剛試了一下老貓的網址

http://www.b-oo-k.net/blog (沒問題)
http://www.b-oo-k.net/blog/1 (不行)

我還在猜有沒有可能是 blog 或是 blog.php 這兩個檔案有問題?

Mark
已記錄

lss
我不是被~拉~~出來的,不要叫我大大!
總版主
超級會員
*****
文章: 1511



檢視個人資料 個人網站
« 回覆文章 #5 於: 四月 11, 2005, 09:42:00 上午 »

啊 mark 你言重了:

想偷懶時,當然要非常非常的客氣 :-p

這個部份,我只是想當然爾的認為 RewriteBase 用不到,但是,在你面前,我真的就不敢確定了。畢竟整個 pLog 系統你比我熟太多了,我又想偷懶一下,省下 trace source 的功夫(下次不敢了 Orz),當然是請你指導了 微笑

當初為了搞中文檔名支援,我個人在 pLog source 上花過時間 trace 過的部份,主要是 gallery 和 url 的部份,其它的,我真的不行…
已記錄

沒找過 常見問題集或不知道 如何在 LifeType 中文開發論壇發問的人,恕不回答問題
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #6 於: 四月 11, 2005, 10:29:56 上午 »

引用自: markwu


我剛剛試了一下老貓的網址

http://www.b-oo-k.net/blog (沒問題)
http://www.b-oo-k.net/blog/1 (不行)

我還在猜有沒有可能是 blog 或是 blog.php 這兩個檔案有問題?

Mark


老貓:

可以請你檢查 一下 /plog 下的 "blog" 跟 "blog.php" 是不是有上傳完整。我在猜可能是這個的問題。

Mark
已記錄

oc
LifeType 中文發展團隊
一般會員
*****
文章: 115


檢視個人資料 個人網站
« 回覆文章 #7 於: 四月 11, 2005, 12:32:44 下午 »

感謝兩位。我重新下載了安裝程式,解開ZIP檔,把.htaccess和error.php再上傳一次。只有更動了.htaccess的那三行,其他都沒變。這樣就完全成功了。試試看:

http://b-oo-k.net/blog/ (成功)
http://b-oo-k.net/blog/1 (也成功)

我沒動 blog 或 blog.php 那兩個檔案,.htaccess檔裡面RewriteBase /plog/ 那一行我也沒動(所以簡潔網址用不到 RewriteBase 的設定) 。

總之,感謝兩位。 開懷大笑
已記錄

南非蜘蛛
新手見習
*
文章: 2


檢視個人資料
« 回覆文章 #8 於: 四月 11, 2005, 01:35:53 下午 »

我要是早看到就好了
这个问题,我0。32的时候就遇到,就这么解决的
哈哈
已記錄

markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #9 於: 四月 11, 2005, 03:41:06 下午 »

引用自: 老貓
感謝兩位。我重新下載了安裝程式,解開ZIP檔,把.htaccess和error.php再上傳一次。只有更動了.htaccess的那三行,其他都沒變。這樣就完全成功了。試試看:

http://b-oo-k.net/blog/ (成功)
http://b-oo-k.net/blog/1 (也成功)

我沒動 blog 或 blog.php 那兩個檔案,.htaccess檔裡面RewriteBase /plog/ 那一行我也沒動(所以簡潔網址用不到 RewriteBase 的設定) 。

總之,感謝兩位。 開懷大笑


恭喜  開懷大笑 !所以真的是上傳不完整。可是你是用什麼 FTP 呢?我用 FileZilla 還沒過過上傳不完整的狀況,可以試試看喔!

Mark
已記錄

頁: [1]
LifeType 中文開發論壇  |  支援  |  安裝與設定  |  [發問]簡潔網址設定成功但主頁連不到(已解決 « 上篇主題 下篇主題 »
    前往: