歡迎光臨, 訪客. 請先 登入註冊一個帳號.
五月 23, 2018, 11:59:54 下午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  開發  |  外掛程式  |  外掛程式精華區  |  [虛擬主機篇] Gallery2 與 P-LOG 整合外掛安裝 « 上篇主題 下篇主題 »
頁: [1]
作者 主題: [虛擬主機篇] Gallery2 與 P-LOG 整合外掛安裝  (閱讀 16678 次)
catseyes
一般會員
***
文章: 189


是我啦是我啦!


檢視個人資料 個人網站
« 於: 十月 06, 2005, 08:50:43 上午 »

好不容易搞好了 Gallery2 有點神精病的搞了一下 Gallery2 與 pLog 的整合外掛 ^^

其實也參照了

http://forum.lifetype.org.tw/index.php?topic=692.0  這一篇以及

http://forum.lifetype.org.tw/index.php?topic=1042.0 這一篇~

綜合整理了一下安裝的方法 ^^ 也希望有不足的地方大家能幫忙補充一下!!

在安裝之前必須先知道你的網頁空間的根目錄位置為何 ^^

如我在 DreamHost 主機上...我的網頁根目錄為 /home/.anabel/使用者稱/網頁資料夾/

各主機商的網頁根目錄都不一樣 ^^ 這可能就必須要自己去了解一下~!!

Step 1. 上傳 Gallery2 至你的主機並且安裝 Gallery2 ( 有點像是廢話 =.= ~改天再來補 Gallery2 安裝方法)

Step 2. 上傳 pLog 的 Gallery 外掛至 plugins

Step 3. 進入 pLog 後台管理程式 --> 個人網誌設定 --> Gallery

Step 4. 點選 "啟動"

Step 5. 於 label_absolute_path  欄位輸入你的網頁根目錄位置 + gallery 的資料夾名稱 + 顯示頁
            如我的主機是 DreamHost 我就輸入 /home/.anabel/帳號/網頁資料夾/Gallery資料夾/embed.php

Step 6. 於 label_embed_uri 輸入你所要給予 Gallery 的 plog 網址~範例如下:
             
引用
/blog/index.php?op=gallery&blogId=1
             如果你的 plog 是直接裝在網頁根目錄下面的話~可以將 /blog/ 給去掉~或者是的 plog 是安裝在其他目錄
             請將 /blog/ 置換成你的 pLog 所安裝的目錄

Step 7. label_embed_path 輸入一個 『 / 』的符號就好...旁邊的引號不要輸入唷!! label_embed_path 是啥意思!?
            我也不知道 >.< 待高手來解答囉!!

Step 8. label_relative_path 輸入你的 gallery 資料夾名稱

Step 9. 按下更新~我目前只有設定這幾個東西...其他的設定我也不知道他們的功能 ^^ 那些也是要高手來幫忙解答一下!

Step 10. 在你想要連結 Gallery 的版模放入以下程式碼...然後按下儲存!!
 
引用
  {if $gallery->isEnabled()}
<a title="My Photos" href="index.php?op=gallery&blogId=1">
{$locale->tr("gallery")}
</a>
{/if}

Step 11.大功告成囉 ^^ 回去你的 blog 看看吧!!也可以到我的 blog 觀看範例 ^^

目前已知問題:
1.好像在簡潔網址 and 自定網址上面使用 Gallery2 與 plog 整合外掛會有些問題
若使用簡潔網址...在連接到 Gallery 的時候 index.php?op=gallery&blogId=1 這段
網址之前會多了一個 /1/ 變成 /1/index.php?op=gallery&blogId=1 導致無法連過
去Gallery 的頁面 ~___~ 不知道是否為我個人問題呢!?

2.除了上述所說的必要設定之外...不知道其他的設定是甚麼呢!?希望有人能協助
說明一下 ^^ 感激不盡呢!!

感謝 Mark~ArthurLin~SlaSh ^^ 不參考他們的文章我可能還沒辦法裝起來呢 ^^
« 最後編輯時間: 十月 06, 2005, 08:52:46 上午 由 catseyes » 已記錄

我的 B-LOG
http://blog.catseyes.com.tw/index.php?blogId=1

虛擬主機資訊
24cc.com 主機
主機系統  Linux
主機類型  i686
Apache 版本 1.3.34 (Unix)
PHP 版本 4.4.1
MySQL 版本 4.1.14-standard-log
=======================
hlps9999
LifeType 中文發展團隊
資深會員
*****
文章: 288



檢視個人資料 個人網站
« 回覆文章 #1 於: 十月 07, 2005, 01:56:38 上午 »

目前已知問題:
1.好像在簡潔網址 and 自定網址上面使用 Gallery2 與 plog 整合外掛會有些問題
若使用簡潔網址...在連接到 Gallery 的時候 index.php?op=gallery&blogId=1 這段
網址之前會多了一個 /1/ 變成 /1/index.php?op=gallery&blogId=1 導致無法連過
去Gallery 的頁面 ~___~ 不知道是否為我個人問題呢!?

2.除了上述所說的必要設定之外...不知道其他的設定是甚麼呢!?希望有人能協助
說明一下 ^^ 感激不盡呢!!

感謝 Mark~ArthurLin~SlaSh ^^ 不參考他們的文章我可能還沒辦法裝起來呢 ^^

1.簡潔網址是可以用的Gallery2的,
會出現那個/1/是因為你將你的blog的簡潔網址打成 http://www.catseyes.com.tw/blog/1/ ,其實應該是http://www.catseyes.com.tw/blog/1 才對(沒有最後面那個/ ),若你的plog是多人使用的,你試試看若輸入 http://www.catseyes.com.tw/blog/1/ 或者 http://www.catseyes.com.tw/blog/2/,其實都會跳回第一個blog去。

但這裡還有個小問題,
若是用簡潔網址,從你的主頁面上(http://www.catseyes.com.tw/blog/1 )連結到你的「Gallery相簿」它的網址會是http://www.catseyes.com.tw/blog/index.php?op=gallery&blogId=1,這裡沒問題。

但你若是連結到某一篇文章(例如:http://www.catseyes.com.tw/blog/post/1/81),這時網頁上面的「Gallery相簿」的連結網址就會變成http://www.catseyes.com.tw/blog/post/1/index.php?op=gallery&blogId=1,這時就會發生「錯誤,找不到您所指定的文章」。

所以解決方法,就是修改連結 Gallery 的版模放入的程式碼
引用
  {if $gallery->isEnabled()}
<a title="My Photos" href="index.php?op=gallery&blogId=1">改成<a title="My Photos" href="http://www.catseyes.com.tw/blog/index.php?op=gallery&blogId=1">
{$locale->tr("gallery")}
</a>
{/if}
這樣就可以了。

2.在作者說明裡有
引用
4. Optionally add the following for image blocks
   {if $gallery->isEnabled()}{$gallery->getImageBlock()}{/if}
你若是將這段程式碼放在你的模版裡,會顯示出gallery2裡的相片,

Blocks裡可以有底下的選擇,選擇一個,就會有一張照片,選擇兩個(中間以|分隔)就會有兩張照片,試試看就知道。
 * randomImage|recentImage|viewedImage|randomAlbum|recentAlbum|viewedAlbum|specificItem
 * dailyImage|weeklyImage|monthlyImage|dailyAlbum|weeklyAlbum|monthlyAlbum

其中「specificItem」,就是指你要出現哪一個特定相簿裡的相片,例如若要出現你那相簿裡的「小 Maru 的三八照」,那麼在「Item ID」那項目裡就要輸入「38」。

至於「Show」那個選項,就是你要在上面的相片下面顯示什麼資訊
title(相簿標題)|date(相簿建立日期|views(瀏覽次數)|owner(相簿擁有者)|heading|fullSize。

最後面那三個選項,我就不知道了。

3.另外你的問題,
「如果說 pLog 內其他的用戶也同樣的在我的 Gallery2 內建立了相本....
是否他們依照說外掛明書上的安裝方法只會顯示我的相本呢!?」

若是其他使用者,在他的blog模版裡,「Gallery相簿」的連結可以加上特定相簿的編號
引用
  {if $gallery->isEnabled()}
<a title="My Photos" href="http://www.catseyes.com.tw/blog/index.php?op=gallery&blogId=1&g2_itemId=相簿編號">
{$locale->tr("gallery")}
</a>
{/if}

若是在blog上要出現上面所說的相片BlocksBlocks選項就選擇「specificItem」,然後在Item ID選項裡輸入相簿的編號,這樣就只會顯示出特定相簿編號裡的相片了。

以上是我的經驗,若有錯誤煩請指正。
已記錄
ajer001
LifeType 中文發展團隊
超級會員
*****
文章: 516


張阿駕


檢視個人資料 個人網站
« 回覆文章 #2 於: 十月 08, 2005, 03:25:37 下午 »

我發現似乎用簡潔網址真的會有問題耶
不知道是我自己的問題還是真的如此
可以煩請各位幫忙測試嗎

我用subdomain+簡潔網址
整合後,可以往下層走
但是如果要回到上層
就會出問題了

另外 整合的話
好像gallery2的rewrite也會掛掉
唉唉
已記錄

|| FreeBSD + Apache 2.x + PHP 5.x + MySQL 5.x ||
-- ajer001 AT twntwn.info --
kennyG
新手見習
*
文章: 21


檢視個人資料
« 回覆文章 #3 於: 十月 11, 2005, 08:43:03 下午 »

 O:)
請問您
小弟在安裝GALLERY2時
每次在外掛程式起動並設定好以後
然後登出再進來
打勾跟所有設定就都取消了
不知道可能是啥原因
另外
設定路徑如果是在本機的話
不知道小弟的設定有沒有錯
請指教
四個設定如下
c:\appserv\www\gallery2\embed.php
index.php?op=gallery&blogId=1
/
gallery2

小弟是用WINXP+SP2
APPSERV 2.4.4A
PLOG1.0.1
已記錄
頁: [1]
LifeType 中文開發論壇  |  開發  |  外掛程式  |  外掛程式精華區  |  [虛擬主機篇] Gallery2 與 P-LOG 整合外掛安裝 « 上篇主題 下篇主題 »
    前往: