歡迎光臨, 訪客. 請先 登入註冊一個帳號.
四月 19, 2024, 03:45:25 上午
19595 文章 在 3865 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  支援  |  安裝與設定  |  【問題】成功的升級了,但遇到怪狀況 « 上篇主題 下篇主題 »
頁: [1]
作者 主題: 【問題】成功的升級了,但遇到怪狀況  (閱讀 9110 次)
bibicall
版主
超級會員
*****
文章: 640


我是豬老大


檢視個人資料 個人網站
« 於: 三月 16, 2005, 11:05:49 下午 »

用老貓大大的零風險方法更新到1.0的0316版成功了
因為我當初是直接就裝在http://www.myblog.com/底下
所以新增了一個new的資料夾
用http://www.myblog.com/new/來測試
該改的url路徑也都改了
但summary中間的最新文章空白一片
旁邊的最多迴響文章、最新網誌的連結也是連回舊路徑
我本來以為是因為我有很多不同的使用者更換模版
我也沒有一個個幫他們換回預設模版測試
所以才會有這個問題,到更新後的後台去改全域設定時候發現
模版選項中有我原來有的那些已經安裝的模版了
但1.0 beta的templates可沒那麼多模版吧^o)
然後我就把模版放置的路徑./templates改成/new/templates
結果整個就當掉了連summary都出現一堆Smarty的錯誤代碼
所以全部砍了,想重新來過
我的疑問是:
1.為何為出現舊版plog的模版呢?因為1.0的templets裡只有最基本的那幾個模版
2.我再次嘗試的話一定得要先安裝完整的舊版,再全部砍掉只留config檔再上傳1.0新版嗎?(Wiki上如是說,還是我誤解了?)
已記錄

我的虛擬主機基本資料如下
Operating system: Linux
Apache version: 1.3.37
PHP version: 4.4.4
MySQL version: 4.1.21-standard
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #1 於: 三月 16, 2005, 11:46:15 下午 »

引用自: bibicall
我的疑問是:
1.為何為出現舊版plog的模版呢?因為1.0的templets裡只有最基本的那幾個模版
2.我再次嘗試的話一定得要先安裝完整的舊版,再全部砍掉只留config檔再上傳1.0新版嗎?(Wiki上如是說,還是我誤解了?)


1. 如果是從 0.32 升級上來,原有的模版ID當然還會繼續存在。因為 migrate 程式只有把該轉換的部分轉換,其他事沒動的。

2. 我比較好奇是你說重裝,然後用一個 new 的 folder,請問你是新安裝的嗎?所以 DB也是不同的了?你是說 summary 會有文章混在一起?

3. 不,不只!例如 /gallery 你當然要留,要不然所以檔案中心檔案都不見了。我建議你先全部備份,只留下 /gallery, /templates, /config。 template 中的模版,如果 1.0 已經有相對應且 porting 的模版,請用新的模版取代。這樣去安裝應該沒問題。多人的 pLog 的升級一定比單人的複雜一些些,因為比較多東西考慮。建議先在測試機器上實驗成功再進行 production 的升級。不要一下就作了,那後悔會來不及。(應該沒那麼嚴重啦) :D

Mark
已記錄

bibicall
版主
超級會員
*****
文章: 640


我是豬老大


檢視個人資料 個人網站
« 回覆文章 #2 於: 三月 17, 2005, 12:17:44 上午 »

引用自: markwu

2. 我比較好奇是你說重裝,然後用一個 new 的 folder,請問你是新安裝的嗎?所以 DB也是不同的了?你是說 summary 會有文章混在一起?

我用老貓大大說得零風險方法,就是將原有的DD複製一個替身成DB2
然後把/config的DB指向DB2
等於就是複製一個現在正在線上的替身來測試升級的問題
所以我的疑問是既然DB2跟DB的資料是一樣的,那升級後
應該在summary也會有已經存在的文章才對
怎會是空白一片?
引用自: markwu
3. 不,不只!例如 /gallery 你當然要留,要不然所以檔案中心檔案都不見了。我建議你先全部備份,只留下 /gallery, /templates, /config。 template 中的模版,如果 1.0 已經有相對應且 porting 的模版,請用新的模版取代。這樣去安裝應該沒問題。多人的 pLog 的升級一定比單人的複雜一些些,因為比較多東西考慮。建議先在測試機器上實驗成功再進行 production 的升級。不要一下就作了,那後悔會來不及。(應該沒那麼嚴重啦) :D

我居然沒考慮到還有檔案中心檔案 目瞪口呆
感謝Mark的提醒
已記錄

我的虛擬主機基本資料如下
Operating system: Linux
Apache version: 1.3.37
PHP version: 4.4.4
MySQL version: 4.1.21-standard
lss
我不是被~拉~~出來的,不要叫我大大!
總版主
超級會員
*****
文章: 1511



檢視個人資料 個人網站
« 回覆文章 #3 於: 三月 17, 2005, 07:26:38 上午 »

引用自: bibicall
用老貓大大的零風險方法更新到1.0的0316版成功了
因為我當初是直接就裝在http://www.myblog.com/底下
所以新增了一個new的資料夾
用http://www.myblog.com/new/來測試
該改的url路徑也都改了

hi bibicall:
你有改 /new/.htaccess 裡的
程式碼:
ErrorDocument 401 /new/error.php
ErrorDocument 401 /new/error.php
ErrorDocument 401 /new/error.php

這些嗎?
尤其你如果用了一般網址模式(簡潔、mod_rewrite、自訂)會出問題的。
已記錄

沒找過 常見問題集或不知道 如何在 LifeType 中文開發論壇發問的人,恕不回答問題
頁: [1]
LifeType 中文開發論壇  |  支援  |  安裝與設定  |  【問題】成功的升級了,但遇到怪狀況 « 上篇主題 下篇主題 »
    前往: