歡迎光臨, 訪客. 請先 登入註冊一個帳號.
一月 17, 2018, 12:01:57 上午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  開發  |  核心補強  |  Lifetype 1.2.3 TinyMCE 於IE無法使用 « 上篇主題 下篇主題 »
頁: 1 [2]
作者 主題: Lifetype 1.2.3 TinyMCE 於IE無法使用  (閱讀 27403 次)
hsiaosh
新手見習
*
文章: 37


檢視個人資料 個人網站
« 回覆文章 #15 於: 六月 13, 2007, 09:52:35 上午 »

我測試升級的情形是:

有重新下載新的1.2.3版囉!

在tiny_mce-plog.js裡加入了
    language : "zh_tw_utf8",

可是如果用了中文語系,是不正常的,在IE裡不能出現那些工具列
不用中文語系,反而才能正常顯示。

使用FireFox卻是正常
目前還在檢查問題中

發現在tinyMCE的plugins裡,我只要在insertaudio與insertvideo 的 langs 資料夾內,加入自己修改的 zh_tw_utf8.js 檔案,便會顯示不出工具列,將 zh_tw_utf8.js 去掉,就恢復正常。

« 最後編輯時間: 六月 13, 2007, 02:25:56 下午 由 hsiaosh » 已記錄

B2D Server 1028版+Apache:2.0.54+PHP:4.3.10+mysql:4.0.24
安裝在:/var/www/plog
lifetype v1.2.5
採用的是從阿駕那兒學來的自訂網址名稱
hlps9999
LifeType 中文發展團隊
資深會員
*****
文章: 288



檢視個人資料 個人網站
« 回覆文章 #16 於: 六月 13, 2007, 03:56:43 下午 »

下午才有老師告知我說在IE下不正常,想了想,之前我本來是正常的(使用zh_tw_utf8)
昨天才去下載那個hotfix lifetype-1.2.3-visual-editor-hotfix-20070611.zip,也許是因為這樣才出現問題吧!

自己搞的亂七八糟的,就把本來的tinymce那目錄移除掉,再拿最新版1.2.3裡的tinymce。

又將自己原本的zh_tw_utf8.js複製回去,至於insertaudio與insertvideo的語系檔,則用原本裡面的en.js複製成zh_tw_utf8.js,再自己手動修改成中文,目前為止是正常OK的。
已記錄
hsiaosh
新手見習
*
文章: 37


檢視個人資料 個人網站
« 回覆文章 #17 於: 六月 13, 2007, 05:15:17 下午 »

阿欣老師

非常謝謝您的提醒,再三詳細核對下,終於發現自己的錯誤
原來,自己修改的語系檔裡,在最後一個項目後面,多了一個「,」
把它刪除掉後,就可以恢復正常了。

感謝!
已記錄

B2D Server 1028版+Apache:2.0.54+PHP:4.3.10+mysql:4.0.24
安裝在:/var/www/plog
lifetype v1.2.5
採用的是從阿駕那兒學來的自訂網址名稱
頁: 1 [2]
LifeType 中文開發論壇  |  開發  |  核心補強  |  Lifetype 1.2.3 TinyMCE 於IE無法使用 « 上篇主題 下篇主題 »
    前往: