歡迎光臨, 訪客. 請先 登入註冊一個帳號.
四月 21, 2018, 03:06:43 上午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  開發  |  核心補強  |  Lifetype 1.2.3 TinyMCE 於IE無法使用 « 上篇主題 下篇主題 »
頁: [1] 2
作者 主題: Lifetype 1.2.3 TinyMCE 於IE無法使用  (閱讀 28205 次)
mouson
新手見習
*
文章: 22



檢視個人資料 個人網站
« 於: 六月 09, 2007, 03:21:04 下午 »

大家好,
目前於http://www.lifetype.net 已經發布了Lifetype 1.2.3
我自己也就將 Lifetype1.2.2 測試站台作了1.2.2 to 1.2.3的升級

但是於升級過後,
發現,在發表文章的時候,
如瀏覽器使用的是IE的話,
會發生無法載入TinyMCE,
並且出現JavaScript 錯誤。





但同樣的環境,
在FireFox卻是正常的。


以上的問題,
我自己有嘗試著去追查相關的原因,
但依然沒有辦法抓到問題的所在,
再麻煩站上的高手幫忙尋找這個錯誤的原因。
已記錄

個人部落格 http://MrMo.cc/mouson
hlps9999
LifeType 中文發展團隊
資深會員
*****
文章: 288



檢視個人資料 個人網站
« 回覆文章 #1 於: 六月 09, 2007, 11:31:15 下午 »

我也才剛由1.2.2升級到1.2.3,不過卻沒有你說的問題

建議你可以先看看「全部站台管控」/「其他設定」/「版本」(這是1.2.3的新功能)
去檢查看看是否有哪些檔案內容是有問題(可能上傳不完整或是被修改過)

記得還要清空一下tmp看看。
已記錄
mouson
新手見習
*
文章: 22



檢視個人資料 個人網站
« 回覆文章 #2 於: 六月 11, 2007, 12:05:39 上午 »

感謝您的建議

剛剛試了一下 其他設定 -> 版本 的 [檢查] Button
出現了以下的警訊

程式碼:
下列的檔案內容有問題(可能上傳不完整或是被修改過):
class/dao/bayesiantokens.class.php
class/mail/phpmailer/class.phpmailer.php
templates/summary/agreement.template
templates/summary/header.template
templates/summary/index.template
templates/summary/post.template
templates/default/commentform.template

對照了一下
lifetype-1.2.2-upgrade-lifetype-1.2.3.zip
裡面的檔案
發現裡面是沒有包含這些檔案的

我自己本身的環境
最早是由1.2.1 -> 1.2.2 -> 1.2.3 延路升級上來的!

templates的部份,
我自己的確有做過更動

其他的檔案,我由1.2.3 的完整包裝
複製到目前的環境之後,
依然還是有同樣的問題。

不知道這樣子提供給大家的資訊是否足夠!
再麻煩大家幫忙看看這會是什麼樣的問題了!!
已記錄

個人部落格 http://MrMo.cc/mouson
hlps9999
LifeType 中文發展團隊
資深會員
*****
文章: 288



檢視個人資料 個人網站
« 回覆文章 #3 於: 六月 11, 2007, 01:22:31 上午 »

參考底下兩篇文章試試

http://forum.lifetype.org.tw/index.php?topic=3060.0
http://forum.lifetype.org.tw/index.php?topic=2858.0
已記錄
bigjj
新手見習
*
文章: 36


檢視個人資料
« 回覆文章 #4 於: 六月 11, 2007, 11:45:52 上午 »

ie7的问题,官方国际站也有提问。http://forums.lifetype.net/viewtopic.php?t=6682
等待。
已記錄

mouson
新手見習
*
文章: 22



檢視個人資料 個人網站
« 回覆文章 #5 於: 六月 11, 2007, 02:32:23 下午 »

的確
目前看到似乎不止我有這個狀況
而且不只是IE7
IE6也會有同樣的問題
已記錄

個人部落格 http://MrMo.cc/mouson
ajer001
LifeType 中文發展團隊
超級會員
*****
文章: 516


張阿駕


檢視個人資料 個人網站
« 回覆文章 #6 於: 六月 11, 2007, 03:33:45 下午 »

今天試了一下,發現opera也會這樣。
有找了一下錯誤訊息,晚上會跟Mark討論看看。
已記錄

|| FreeBSD + Apache 2.x + PHP 5.x + MySQL 5.x ||
-- ajer001 AT twntwn.info --
gzm55
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #7 於: 六月 11, 2007, 04:17:41 下午 »

我升级后也遇到这个问题了,后来用tinymce 2.1.1.1替换掉原来的 2.10 版本,现在IE6、OPERA、FF都正常了。
已記錄
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #8 於: 六月 12, 2007, 12:46:36 上午 »

這是 bug, 剛剛已經在 SVN 上修復了。

Mark
已記錄

ajer001
LifeType 中文發展團隊
超級會員
*****
文章: 516


張阿駕


檢視個人資料 個人網站
« 回覆文章 #9 於: 六月 12, 2007, 11:12:48 上午 »

感謝 Mark!

可以參考:
http://twntwn.info/blog/ajer001/archives/1936
http://www.lifetype.net/blog/lifetype-development-journal/2007/06/11/problems-with-tinymce-in-lifetype-1.2.3-hotfix-and-updated-packages-available

快修正吧!
已記錄

|| FreeBSD + Apache 2.x + PHP 5.x + MySQL 5.x ||
-- ajer001 AT twntwn.info --
hlps9999
LifeType 中文發展團隊
資深會員
*****
文章: 288



檢視個人資料 個人網站
« 回覆文章 #10 於: 六月 12, 2007, 11:35:12 上午 »

我這邊一直沒出現這問題,原來是因為tinymce裡我用的是"zh_tw_utf8",所以沒影響。
已記錄
ajer001
LifeType 中文發展團隊
超級會員
*****
文章: 516


張阿駕


檢視個人資料 個人網站
« 回覆文章 #11 於: 六月 12, 2007, 01:17:51 下午 »

沒錯,中獎的都是用原本的英文語系的。
看來等下要來仿效,用一下中文了。
已記錄

|| FreeBSD + Apache 2.x + PHP 5.x + MySQL 5.x ||
-- ajer001 AT twntwn.info --
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #12 於: 六月 12, 2007, 01:20:44 下午 »

那是 check 時沒有檢查,所以 Oscar 覺得很幹,直說下一次 Minor 釋出也要來個 Beta 測試。

Mark
已記錄

ajer001
LifeType 中文發展團隊
超級會員
*****
文章: 516


張阿駕


檢視個人資料 個人網站
« 回覆文章 #13 於: 六月 12, 2007, 02:20:52 下午 »

哈哈,應該是忙中有錯。
結果這兩次.x釋出,都變成還要追加hotfix。:P
已記錄

|| FreeBSD + Apache 2.x + PHP 5.x + MySQL 5.x ||
-- ajer001 AT twntwn.info --
gzm55
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #14 於: 六月 12, 2007, 07:56:37 下午 »

简体中文也中奖了...
已記錄
頁: [1] 2
LifeType 中文開發論壇  |  開發  |  核心補強  |  Lifetype 1.2.3 TinyMCE 於IE無法使用 « 上篇主題 下篇主題 »
    前往: