歡迎光臨, 訪客. 請先 登入註冊一個帳號.
十二月 12, 2018, 03:27:09 下午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  測試  |  LifeType 1.0 測試  |  關於 mysql 4.1 « 上篇主題 下篇主題 »
頁: [1]
作者 主題: 關於 mysql 4.1  (閱讀 17787 次)
darkhero
初級會員
**
文章: 58


檢視個人資料 個人網站
« 於: 三月 23, 2005, 01:23:39 下午 »

不知道各位有沒有在 mysql 4.1 以上安裝過 plog ....

安裝過程正常,使用正常,但是若用 phpMyAdmin-2.6.1 以上去檢視管理資料庫的話.
會發現資料是亂碼....

但是當我修正好資料庫編碼的問題,一搬來說以 phpbb2 之類在資料庫連線後需要手動加上 set names utf8,但是剛剛發現 plog1.0 似乎不用...
不知道是否 plog1.0 目前是否有對 mysql 4.1 以上的 charset 功能有作處理呢?...

關於 mysql 4.1 的 charset 會造成的影響或許可以參考我之前寫的這篇...
http://phorum.study-area.org/viewtopic.php?t=29392

以下是我的測試方式:.

而剛剛小弟有測試過,在 mysql4.1 安裝好 plog 1.0 後,用 phpMyAdmin-2.6.1 去檢視資料庫會顯示亂碼(可能是因為我server預設 latin1,而大部分rpm安裝的mysql都預設 latin1),所以我就將 database dump 下來後修改了 create table 的預設語系修改..
從 latin1 改為 utf8 然後 set names utf8 重新匯入資料庫.

如此從 phpMyAdmin 之中檢視,可以正確顯示資料內容.
使用 mysql command 去測試.
mysql -u root -pxxxxx plog10

執行以下 command
set names big5;
SELECT * FROM plog_articles_text;

若是顯示也是正常的 big5內容 則是正確,因為 mysql4.1 會根據 client charset 轉換 content charset .

這時候回 plog 線上檢視,發現內容正常...
已記錄

markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #1 於: 三月 23, 2005, 04:10:09 下午 »

Hi Darkhero:

不好意思!資料庫真的不是我的強項。但是我記得在 1.0 測試之初 pest 就做了一個 patch來解決 set name utf-8 的問題。但是呢?他講到一個例外狀況。好像就是你講的情形,能請你參考一下這個討論嗎?

http://forum.lifetype.org.tw/index.php?topic=47.0

Mark
已記錄

darkhero
初級會員
**
文章: 58


檢視個人資料 個人網站
« 回覆文章 #2 於: 三月 23, 2005, 09:02:52 下午 »

Hi Markwu

看樣子的確是有做一些修正...

所以 plog1.0 在資料庫連線的時候會預設 client 會以 utf8 進行連線...
所以存入的資料雖然會經過 mysql4.1 轉換進資料庫後會在其他情況下變成亂碼...
但是基本上取出的時候因為會反轉,所以運氣好就正常囉....

不過若是在安裝流程中也加上 create table 的 default charset 似乎反而會讓 mysql 4.1 以下的會有問題.

或許這方面就等大部分都用4.1或是將來安裝 sql 部分有需要針對 mysql4.1 等作修正的時候在處理好囉..^_^..

至少目前看來直接在 mysql 4.1 下 install 後..可以利用我那個測試時後的方法讓資料庫編碼與內容是一致的~...
已記錄

markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #3 於: 三月 24, 2005, 10:32:10 上午 »

要不然,就是安裝時判斷 mysql 版本,執行不同的安裝 sql。你覺得呢?這樣應該就可以避免編碼的問題。

Mark
已記錄

darkhero
初級會員
**
文章: 58


檢視個人資料 個人網站
« 回覆文章 #4 於: 三月 24, 2005, 01:20:30 下午 »

引用自: markwu
要不然,就是安裝時判斷 mysql 版本,執行不同的安裝 sql。你覺得呢?這樣應該就可以避免編碼的問題。

Mark


是可以的...
不過我還沒有檢視過 plog10 的安裝部份的程式碼,所以不清楚 plog10 的 sql 部份是獨立一個檔案匯入資料庫,或是從 install scrtip 去產生的.

若是由 install script 產生的則是要修改 install script , 這方面或許對於目前已經接近 release 的情況下,我想可以先不用即刻修改.

若是 SQL 資料檔案是獨立一個的話,或許可以直接匯入mysql41 後匯出一個 包含 預設 default charset 的版本...

個人是傾向先不用改拉...^_^.. 現在的情況是可以正常運作...
只是要用 phpMyAdmin 去檢查資料庫需要動點點手腳而已....
並不會構成實際使用上的問題~
已記錄

markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #5 於: 三月 25, 2005, 01:05:03 下午 »

那麼我們就把這個議題移到 1.1 再來做。能請你 create 一個 feature request 在 bugs.lifetype.net 嗎?

Mark
已記錄

darkhero
初級會員
**
文章: 58


檢視個人資料 個人網站
« 回覆文章 #6 於: 三月 30, 2005, 08:51:33 上午 »

引用自: markwu
那麼我們就把這個議題移到 1.1 再來做。能請你 create 一個 feature request 在 bugs.lifetype.net 嗎?

Mark


不好意思現在才來看到這篇....
小弟英文差..我怕我去寫的他們會看不懂ㄟ..Q_Q...
已記錄

頁: [1]
LifeType 中文開發論壇  |  測試  |  LifeType 1.0 測試  |  關於 mysql 4.1 « 上篇主題 下篇主題 »
    前往: