歡迎光臨, 訪客. 請先 登入註冊一個帳號.
七月 11, 2020, 07:54:33 上午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  開發  |  外掛程式  |  加入「迴響認證」時出現的錯誤,「xhtmlize」 « 上篇主題 下篇主題 »
頁: [1]
作者 主題: 加入「迴響認證」時出現的錯誤,「xhtmlize」  (閱讀 12269 次)
windmill
新手見習
*
文章: 6


檢視個人資料
« 於: 二月 23, 2005, 12:57:59 下午 »

引用
Fatal error: Call to undefined function: xhtmlize() in c:\appserv\www\plog\class\action\addcommentaction.class.php on line 70

可以請教一下這是怎樣的錯誤~~?


對了,我的驗證碼出現附檔名耶,例如產生「AID.tmp」,驗證碼則出現「ID.tmp」,不曉得為何會這樣?
已記錄
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #1 於: 二月 23, 2005, 01:54:38 下午 »

這應該是安裝錯誤耶!

你能講以一下你的安裝方式嗎?或是讓我們看你的網站一下。

Mark
已記錄

windmill
新手見習
*
文章: 6


檢視個人資料
« 回覆文章 #2 於: 二月 23, 2005, 06:02:14 下午 »

你好~~
我的網址:
http://windmill.myvnc.com/plog/
我是下載「plog-plugin-authimage-20041206.class.rar」解壓縮後放到
windmill.myvnc.com/plog/目錄下,我記得有三個目錄分別是authimage、class、plugins,authimage直接拷貝而class與plugins是以覆蓋方式拷貝。

我是亂包版PLOG,修改reicfull模版下的commentform.template
內容與安插位置如下

引用
<div class="comments-body">
  <form name="NewComment" action="{$url->getBaseUrl()}/index.php" method="post" onsubmit="if (this.bakecookie[0].checked) rememberMe(this)">
  <div style="width:150px; padding-right:15px; margin-right:15px; float:left; text-align:left; border-right:1px dotted #bbb;">
   <label for="subject">{$locale->tr("comment_topic")}:</label><br />
   <input tabindex="1" id="subject" name="commentTopic" /><br /><br />
   <label for="author">{$locale->tr("comment_username")}:</label><br />
   <input tabindex="2" id="author" name="userName" /><br /><br />
   <label for="email">{$locale->tr("comment_email")}:</label><br />
   <input tabindex="3" id="email" name="userEmail" /><br /><br />
   <label for="url">{$locale->tr("comment_url")}:</label><br />
   <input tabindex="4" id="url" name="userUrl" /><br /><br />
   <label>記錄個人資訊:</label><br />
   <input type="radio" id="bakecookie" name="bakecookie" />
   <label for="bakecookie">是</label>
   <input type="radio" id="forget" name="bakecookie" onclick="forgetMe(this.form)" value="Forget Info" style="margin-left: 15px;" />
   <label for="forget">否</label><br style="clear: both;" /><br />
  </div>
 <div>
  Enter this code <input type="text" size="20" name="commentAuthCode" value=""/> {$authimage->show()}<BR>
  <label for="text">{$locale->tr("add_comment")}:</label><br />
  {* quicktags plugin *}
  <script type="text/javascript">edToolbar();</script><br/>
  {* quicktags end *}
  <textarea tabindex="5" id="text" name="commentText" rows="10" cols="40"></textarea><br />
  {* quick tags & smiley plugin *}
  <script type="text/javascript">var edCanvas = document.NewComment.commentText;</script>
  {$smileys->generateSmileysBar()}
  {* smiley end *}
  <br />  
  <input style="font-weight: bold;" type="submit" name="post" value="&nbsp;{$locale->tr("comment_send")}&nbsp;" />
  &nbsp;&nbsp;<input style="font-weight: bold;" type="reset"><br /><br />
  <input type="hidden" name="op" value="AddComment"/>
  <input type="hidden" name="articleId" value="{$post->getId()}"/>
  <input type="hidden" name="blogId" value="{$blog->getId()}"/>
  <input type="hidden" name="parentId" value="{$parentId}"/>
  </div>
  </form>
</div>


然後到外掛程式中心,依照說明勾選enable與驗證前置碼AI與顏色。
GD是新版的所以也改成*PNG*(不是很清楚這部分,總之改後我就看的見圖案了)
目前就是驗證會出現錯誤訊息,不知道為何會如此?
請教一下我該如何努力?
已記錄
reic
LifeType 中文發展團隊
初級會員
*****
文章: 57


檢視個人資料 個人網站
« 回覆文章 #3 於: 二月 23, 2005, 09:57:20 下午 »

引用自: windmill
你好~~
我的網址:
http://windmill.myvnc.com/plog/
我是下載「plog-plugin-authimage-20041206.class.rar」解壓縮後放到
windmill.myvnc.com/plog/目錄下,我記得有三個目錄分別是authimage、class、plugins,authimage直接拷貝而class與plugins是以覆蓋方式拷貝。

我是亂包版PLOG,修改reicfull模版下的commentform.template
內容與安插位置如下


然後到外掛程式中心,依照說明勾選enable與驗證前置碼AI與顏色。
GD是新版的所以也改成*PNG*(不是很清楚這部分,總之改後我就看的見圖案了)
目前就是驗證會出現錯誤訊息,不知道為何會如此?
請教一下我該如何努力?


我看你很正常啊,沒有錯誤的訊息啊
在認證碼那邊也沒有出現  什麼錯誤啊。
windmill: 你的名子和我的一個國中同學好像喔。
你是台中人嗎?
已記錄

歡迎光臨 Reic's place
windmill
新手見習
*
文章: 6


檢視個人資料
« 回覆文章 #4 於: 二月 24, 2005, 12:32:31 上午 »

引用自: reic
引用自: windmill
你好~~
我的網址:
http://windmill.myvnc.com/plog/
我是下載「plog-plugin-authimage-20041206.class.rar」解壓縮後放到
windmill.myvnc.com/plog/目錄下,我記得有三個目錄分別是authimage、class、plugins,authimage直接拷貝而class與plugins是以覆蓋方式拷貝。

我是亂包版PLOG,修改reicfull模版下的commentform.template
內容與安插位置如下


然後到外掛程式中心,依照說明勾選enable與驗證前置碼AI與顏色。
GD是新版的所以也改成*PNG*(不是很清楚這部分,總之改後我就看的見圖案了)
目前就是驗證會出現錯誤訊息,不知道為何會如此?
請教一下我該如何努力?


我看你很正常啊,沒有錯誤的訊息啊
在認證碼那邊也沒有出現  什麼錯誤啊。
windmill: 你的名子和我的一個國中同學好像喔。
你是台中人嗎?

可能你沒有實際留下迴響,如果實際留下迴響,就會發現問題了!也就是根本不能留下迴響~~唉~
還有我應該不是你同學,因為我台北住了二十五年~呵呵~是道地台北人
已記錄
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #5 於: 二月 24, 2005, 01:09:15 上午 »

的確是錯誤!而且是錯在最不可能錯的地方。因為你可以看一下 class\actions\addcommentaction.class.php 這個檔。這一行我並沒有改到,可是你卻錯在這一行。

另外你的驗證碼的確顯示錯誤!

實在不知道原因。你是在 Linux 下 run 的嗎?我唯一想的到的原因是,有可能我是在 windows 下編輯,他的斷行跟 Linux 不一樣所以造成錯誤嗎?

你可以用 VIM 或是 emacs 試試看,把這些檔案重新編輯與儲存,在試試看嗎?

Mark
已記錄

windmill
新手見習
*
文章: 6


檢視個人資料
« 回覆文章 #6 於: 二月 24, 2005, 09:59:56 上午 »

引用自: markwu
的確是錯誤!而且是錯在最不可能錯的地方。因為你可以看一下 class\actions\addcommentaction.class.php 這個檔。這一行我並沒有改到,可是你卻錯在這一行。

另外你的驗證碼的確顯示錯誤!

實在不知道原因。你是在 Linux 下 run 的嗎?我唯一想的到的原因是,有可能我是在 windows 下編輯,他的斷行跟 Linux 不一樣所以造成錯誤嗎?

你可以用 VIM 或是 emacs 試試看,把這些檔案重新編輯與儲存,在試試看嗎?

Mark

我也覺得奇怪~~我在想有兩種可能,一個是我動到了一些必要的檔案內容,另一個就是亂包版的檔案內容被修改過,以致於與預設值不同。但是同樣都超出我能力所及,因為我只懂簡單的HTML語法,其他部分都是用猜的。還有,我是在windowsXP上架設appserv的,所以我並不熟VIM與emacs(這是不是linux的編輯工具呀!?),我用dreamweaver編輯這個檔案,不過我只是「看」而已,因為我不懂,~~呵呵~~。
那的確是最不可能錯的地方,所以看到這行時,我心裡冷了一下,用GOOGLE查詢,全世界似乎沒有人對這行有興趣,呵呵~~ 開懷大笑
藉此機會,我要感謝馬克先生的指導。我現在在找是否還有其他方法,可以阻擋垃圾迴響,如隱藏格或偵測全行字,不過我還是不懂那些語法呀!殘念!~ 開懷大笑
已記錄
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #7 於: 二月 24, 2005, 06:11:48 下午 »

我的環境跟你一樣阿!mmm .... 真的不知道原因。

建議你升級到 1.0 該有的檔垃圾迴響得方式,我幾乎都已經porting 到 1.0 了。

Mark
已記錄

頁: [1]
LifeType 中文開發論壇  |  開發  |  外掛程式  |  加入「迴響認證」時出現的錯誤,「xhtmlize」 « 上篇主題 下篇主題 »
    前往: