歡迎光臨, 訪客. 請先 登入註冊一個帳號.
六月 21, 2018, 11:16:40 上午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  測試  |  LifeType 1.0 測試  |  plog1.0_Beta版 資料夾上傳圖示無法顯示 « 上篇主題 下篇主題 »
頁: 1 2 [3]
作者 主題: plog1.0_Beta版 資料夾上傳圖示無法顯示  (閱讀 74952 次)
king
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #30 於: 三月 17, 2005, 07:56:59 上午 »

引用自: lss
hi king:
剛剛去你的主機上看過了,請收私人信息。
目前的診斷是你的 PHP 對 GD 的支援有問題。
可能得看看 FC3 的 PHP 是否有新版,要更新一下,看能不能解決這個問題。
祝好運!


謝謝lss大熱心幫忙
感謝感謝~~ 開懷大笑
已記錄

我的環境:
 Fedora Core 4
Apache 2.0.54
mysql 4.1.12
php 5.0.4-10.4
lss
我不是被~拉~~出來的,不要叫我大大!
總版主
超級會員
*****
文章: 1511



檢視個人資料 個人網站
« 回覆文章 #31 於: 三月 17, 2005, 09:31:31 上午 »

hi king:
看來問題解決了,恭喜了。
能不能貼篇心得,讓 mark 加入精華區?
已記錄

沒找過 常見問題集或不知道 如何在 LifeType 中文開發論壇發問的人,恕不回答問題
king
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #32 於: 三月 17, 2005, 09:42:28 上午 »

引用自: lss
hi king:
看來問題解決了,恭喜了。
能不能貼篇心得,讓 mark 加入精華區?


我....我有這麼說嗎 戴太陽眼鏡 ""
目前尚未解決但lss大大已給了幾個方向(又燃起希望)
我會再去試如果ok的話必定把解決方法發表出來
另外我也很想知道當初發表這篇主題的 kochlin 不知是否已找出解答了
已記錄

我的環境:
 Fedora Core 4
Apache 2.0.54
mysql 4.1.12
php 5.0.4-10.4
kochlin
新手見習
*
文章: 46


檢視個人資料
« 回覆文章 #33 於: 三月 17, 2005, 11:27:54 上午 »

引用自: king
引用自: lss
hi king:
看來問題解決了,恭喜了。
能不能貼篇心得,讓 mark 加入精華區?


我....我有這麼說嗎 戴太陽眼鏡 ""
目前尚未解決但lss大大已給了幾個方向(又燃起希望)
我會再去試如果ok的話必定把解決方法發表出來
另外我也很想知道當初發表這篇主題的 kochlin 不知是否已找出解答了


我在等最高管理者回來幫我解決PHP GD問題,不過我的easyphp 1.8是最新的
easyphp 1.8 : apache 1.3.33 - php 4.3.10 - mysql 4.1.9 - phpmyadmin 2.6.1
 傷心
還是有同樣錯誤,問問線上朋友有沒有跟我同情況
XP + easyphp 1.8 + Plog1.0
已記錄
king
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #34 於: 三月 19, 2005, 07:08:55 下午 »

關於無法產生縮圖的問題目前找到一替代方案
由於已經 update 過 PHP 仍然無效於是乎轉向安裝 ImageMagick 求解
在此分享給也有需要的朋友們

1) 至 http://www.imagemagick.org/script/binary-releases.php?
    下載 RPM 檔

2) 安裝該 RPM
3) 進入pLog 的管理介面
4) 依序找到 檔案設定中心 -> thumbnail_method
    選擇「ImageMagick」
5) 依序找到 檔案設定中心 -> path_to_convert
    填入「/usr/bin/convert」
6) 完成

附帶一提我只有試過在 Fedora Core 3 上裝過,是ok的
已記錄

我的環境:
 Fedora Core 4
Apache 2.0.54
mysql 4.1.12
php 5.0.4-10.4
smiling ox
訪客
« 回覆文章 #35 於: 三月 19, 2005, 08:31:15 下午 »

http://www.iblog.cn/index.php?op=ViewAlbum&albumId=2&blogId=4

我的环境:linux+php+mysql+gd1
已記錄
kochlin
新手見習
*
文章: 46


檢視個人資料
« 回覆文章 #36 於: 三月 20, 2005, 08:06:42 上午 »

引用自: king
關於無法產生縮圖的問題目前找到一替代方案
由於已經 update 過 PHP 仍然無效於是乎轉向安裝 ImageMagick 求解
在此分享給也有需要的朋友們

1) 至 http://www.imagemagick.org/script/binary-releases.php?
    下載 RPM 檔

2) 安裝該 RPM
3) 進入pLog 的管理介面
4) 依序找到 檔案設定中心 -> thumbnail_method
    選擇「ImageMagick」
5) 依序找到 檔案設定中心 -> path_to_convert
    填入「/usr/bin/convert」
6) 完成

附帶一提我只有試過在 Fedora Core 3 上裝過,是ok的

=========================================
Fedora Core 3上替代方案己經解決了問題   Thank's
但是我的另一個問題還存在,就是每渙一個點選項目一定失敗,必須要按重新整理才能看到網頁。
http://plog1.read.org.tw/
不知您是否也遇到相同問題?
已記錄
king
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #37 於: 三月 20, 2005, 10:48:23 上午 »

引用自: kochlin
引用自: king
關於無法產生縮圖的問題目前找到一替代方案
由於已經 update 過 PHP 仍然無效於是乎轉向安裝 ImageMagick 求解
在此分享給也有需要的朋友們

1) 至 http://www.imagemagick.org/script/binary-releases.php?
    下載 RPM 檔

2) 安裝該 RPM
3) 進入pLog 的管理介面
4) 依序找到 檔案設定中心 -> thumbnail_method
    選擇「ImageMagick」
5) 依序找到 檔案設定中心 -> path_to_convert
    填入「/usr/bin/convert」
6) 完成

附帶一提我只有試過在 Fedora Core 3 上裝過,是ok的

=========================================
Fedora Core 3上替代方案己經解決了問題   Thank's
但是我的另一個問題還存在,就是每渙一個點選項目一定失敗,必須要按重新整理才能看到網頁。
http://plog1.read.org.tw/
不知您是否也遇到相同問題?


我去該網址瀏覽了一下看起來一切ok
點選什麼都很正常的顯示呀
我之前有遇過頁面顯示不完整的問題大概是我想到的最接近的情況吧
只要修改 /etc/php.ini 裡面
把 memory_limit 改成 16M 就能解決了
希望對你有幫助

ps: 可以請問一下您的網址在哪兒申請的嗎 吐舌頭
已記錄

我的環境:
 Fedora Core 4
Apache 2.0.54
mysql 4.1.12
php 5.0.4-10.4
tripc
新手見習
*
文章: 11


檢視個人資料
« 回覆文章 #38 於: 四月 01, 2005, 10:42:02 上午 »

我也發生過類似問題
是從MDK換到FEDORA時發生的
後來發現, 在 PHP.INI中, 把MEMORY BUFFER改大以後
問題就解決了
預設值是 8 MB, 我改成了 60MB  戴太陽眼鏡
你可以試看看 !!
已記錄
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #39 於: 四月 01, 2005, 02:03:43 下午 »

引用自: tripc
我也發生過類似問題
是從MDK換到FEDORA時發生的
後來發現, 在 PHP.INI中, 把MEMORY BUFFER改大以後
問題就解決了
預設值是 8 MB, 我改成了 60MB  戴太陽眼鏡
你可以試看看 !!


60MB,太可怕了!我只設到 16MB。

Mark
已記錄

xrush
新手見習
*
文章: 5


檢視個人資料
« 回覆文章 #40 於: 四月 14, 2005, 12:25:21 上午 »

不好意思,借用此欄發問一下:

小弟的照片已能夠成功上傳,在「檔案列表」頁中也看得到縮圖,但是頁首卻有一串錯誤訊息如下:

引用

Exception message: filesize(): Stat failed for C:\WINNT\TEMP\php28C.tmp (errno=2 - No such file or directory)
Error code: 2
-- Backtrace --
D:\wwwroot\plog\class\gallery\getid3\getid3.php(167):
Notice: Undefined index: class in D:\wwwroot\plog\class\object\exception.class.php on line 51
filesize
D:\wwwroot\plog\class\gallery\dao\galleryresources.class.php(450): getid3.analyze
D:\wwwroot\plog\class\action\admin\adminaddresourceaction.class.php(78): galleryresources.addresource
D:\wwwroot\plog\class\controller\controller.class.php(305): adminaddresourceaction.perform
D:\wwwroot\plog\admin.php(36): admincontroller.process

Exception message: fread(): Length parameter must be greater than 0.
Error code: 2
-- Backtrace --
D:\wwwroot\plog\class\gallery\getid3\module.graphic.jpg.php(32): getid3_lib.fread
D:\wwwroot\plog\class\gallery\getid3\getid3.php(309): getid3_jpg.getid3_jpg
D:\wwwroot\plog\class\gallery\dao\galleryresources.class.php(450): getid3.analyze
D:\wwwroot\plog\class\action\admin\adminaddresourceaction.class.php(78): galleryresources.addresource
D:\wwwroot\plog\class\controller\controller.class.php(305): adminaddresourceaction.perform
D:\wwwroot\plog\admin.php(36): admincontroller.process

Exception message: Cannot modify header information - headers already sent by (output started at D:\wwwroot\plog\class\object\exception.class.php:37)
Error code: 2
-- Backtrace --
D:\wwwroot\plog\class\view\view.class.php(172):
Notice: Undefined index: class in D:\wwwroot\plog\class\object\exception.class.php on line 51
header
D:\wwwroot\plog\class\view\view.class.php(308): adminresourceslistview.sendcontenttype
D:\wwwroot\plog\class\view\admin\adminview.class.php(106): view.render
D:\wwwroot\plog\class\view\admin\admintemplatedview.class.php(36): adminview.render
D:\wwwroot\plog\class\view\admin\adminresourceslistview.class.php(104): admintemplatedview.render
D:\wwwroot\plog\class\controller\controller.class.php(325): adminresourceslistview.render
D:\wwwroot\plog\admin.php(36): admincontroller.process


PS.路徑沒錯,我的網站根目錄不是放在IIS預設的目錄內....

由於主機中還有其他的客戶網站,小弟只能用IIS+PHP+MySQL來架設plog,不知是否平台問題,由於第一次架設plog,算是剛加入plog的菜鳥..希望各位前輩不吝指導,謝謝! 害羞
已記錄
xrush
新手見習
*
文章: 5


檢視個人資料
« 回覆文章 #41 於: 四月 14, 2005, 01:03:47 上午 »

上篇問題已解決,把.htaccess刪掉頁面就正常顯示了,希望不會有太嚴重的後遺症... 傷心
已記錄
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #42 於: 四月 14, 2005, 11:16:11 上午 »

沒問題的!只是你沒辦法使用簡潔網址與自訂網址的功能。 開懷大笑

不過在 IIS 下本來就用不到的!嘻嘻! 開懷大笑

Mark
已記錄

頁: 1 2 [3]
LifeType 中文開發論壇  |  測試  |  LifeType 1.0 測試  |  plog1.0_Beta版 資料夾上傳圖示無法顯示 « 上篇主題 下篇主題 »
    前往: