歡迎光臨, 訪客. 請先 登入註冊一個帳號.
一月 19, 2018, 02:36:06 下午
19594 文章 在 3864 主題 由 4580 會員
最新註冊會員: aa123aa1
LifeType 中文開發論壇  |  開發  |  外掛程式  |  外掛程式精華區  |  1.0.2 中 juploadNewResource 不能用? « 上篇主題 下篇主題 »
頁: [1] 2
作者 主題: 1.0.2 中 juploadNewResource 不能用?  (閱讀 27530 次)
bigsea622
新手見習
*
文章: 12



檢視個人資料
« 於: 七月 25, 2005, 04:06:18 下午 »

1.0.2 中 juploadNewResource  不能用?
我去 jupload 的网站看了一下 ,这个 外掛 是否是 收費的?
已記錄

php4.4.0+apache1.3.3+mysql4.0+plog1.0.1
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #1 於: 七月 27, 2005, 01:02:12 下午 »

引用自: bigsea622
1.0.2 中 juploadNewResource  不能用?
我去 jupload 的网站看了一下 ,这个 外掛 是否是 收費的?


不能用是什麼意思?是 java applet 出不來,還是?

Mark
已記錄

rainlan
初級會員
**
文章: 58


檢視個人資料
« 回覆文章 #2 於: 七月 27, 2005, 09:26:33 下午 »

我也是無法顯示出來耶
一片灰灰的
是用maxthon瀏覽器
已記錄

主機環境
Fedora Core 3
pLog 1.02
Apache版本2.0.50
MySQL版本3.23.58
bigsea622
新手見習
*
文章: 12



檢視個人資料
« 回覆文章 #3 於: 八月 09, 2005, 04:03:43 下午 »

引用自: markwu
引用自: bigsea622
1.0.2 中 juploadNewResource  不能用?
我去 jupload 的网站看了一下 ,这个 外掛 是否是 收費的?


不能用是什麼意思?是 java applet 出不來,還是?

Mark

能用暸,java applet 下載下來 安裝就能用暸.
已記錄

php4.4.0+apache1.3.3+mysql4.0+plog1.0.1
tmtzong
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #4 於: 九月 30, 2005, 10:27:24 上午 »

關於JUpload使用的問題:
我的測試環境是 Server端在XP,安裝 appserv-win32-2.4.4a.exe,client端為winxp+IE
使用 plog1.0 會出現正常的上傳頁面:JUpload 上傳檔案外掛程式
如果安裝 是plog1.01,上傳頁面就看不到
同樣機器,同樣環境,不下十來次,每次的結果都是一樣。
請問 是哪個環節出了問題?

挫敗中倒是發現:
jupload\templates\pluginsettings.template 檔案中
{$locale->tr("jupload_plugin_enabled")} 誤為 {$locale->tr("templateeditor_plugin_enabled")}

plugins\jupload\locale\locale_zh_TW.php 檔案中
$messages["jupload_plugin_enabled"] = "啟用Java Applet - JUpload 上傳檔案外掛程式";
同樣是 弄錯  為templateeritor_plugin_enabled

還是在下使用的檔案有問題?
謝謝
已記錄

TMTZONG
FreeBSD 5.0 Release
Apache 2.0.47 | MySQL 3.23.54  | PHP Version 4.4.0
Plog 1.02 Beta
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #5 於: 九月 30, 2005, 12:21:00 下午 »

Hi tmtzong:

請從新下載 jupload plugin, 我上次已經把正確的 upload 上去了,但不知為什麼他還是舊的檔案。  傷心

http://prdownloads.sourceforge.net/plog/jupload.zip?download

Mark
已記錄

tmtzong
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #6 於: 十月 01, 2005, 11:24:49 上午 »

謝謝您,jupload 功能都已正常。
抱歉,因檔案使用的來源都來自『鑫智數位』的(架設我的部落格王國)所附CD,
在下會重新測試其他檔案。

有您的指導,受益匪淺,謝謝。
已記錄

TMTZONG
FreeBSD 5.0 Release
Apache 2.0.47 | MySQL 3.23.54  | PHP Version 4.4.0
Plog 1.02 Beta
tmtzong
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #7 於: 十月 02, 2005, 07:57:27 下午 »

您好
又來請教了!
Jupload外掛 其介面下方出現:(左上半部會有待上傳的檔案清單,左下半部 灰色,右邊有4個command Button)

Your browser does not support applets. Or you have disabled applet in your options. To use this applet, please install the newest version of Sun's java. You can get it from java.com

但連上 java.com 又可看到"咖啡飄香"。(已安裝數次又重開機)

如果直接 Add Files & upload Files,會看到 上傳百分比漸達 100%,然後 waitting for Answer,上傳的檔案清單會清成空白,就這樣傳完檔案,然後按一下檔案中心,就被踢出管理者介面,回到首頁。
當然剛上傳的檔案並未在『檔案中心』裡。

抱歉怕說得不清楚,扯那麼長。
其他外掛,就算 gallery2 也一次OK,這Jupload 就那麼難纏,真不死心,尚望指教,謝謝。
已記錄

TMTZONG
FreeBSD 5.0 Release
Apache 2.0.47 | MySQL 3.23.54  | PHP Version 4.4.0
Plog 1.02 Beta
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #8 於: 十月 03, 2005, 11:48:32 上午 »

你是用哪一版的 pLog 呢?請換到 1.0.2 ,我剛剛試過並沒有這樣問題。

Mark
已記錄

tmtzong
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #9 於: 十月 03, 2005, 04:25:02 下午 »

知道了
在下先在另一台機器上 測 1.02 beta版 若可以。
再UPgrade 1.01 到 1.02,若不行, 就重灌(希望一切順利)

謝謝您繼續指導
已記錄

TMTZONG
FreeBSD 5.0 Release
Apache 2.0.47 | MySQL 3.23.54  | PHP Version 4.4.0
Plog 1.02 Beta
tmtzong
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #10 於: 十月 03, 2005, 07:28:29 下午 »

剛剛已經重裝1.02 Beta 與 jupload,甚至連apache Package 都改用最新版 appserv-win32-2.5.4a.exe,java 也重裝 j2re-1_4_2-windows-i586.exe

上傳檔案的結果發現:不論是利用Jupload 介面 or plog內建之新增檔案,只要一個檔案超過 2M  該檔案就無法成功上傳,其他小檔案就OK,就算到全站設定/上傳設定改到200000000(200M),仍舊失敗,不知您傳過超過2M以上檔案否?

希望不是機器的問題(用了三台)也不是PLOG本身的問題,難道是OS(XP)作怪,在下仍抱一絲希望,仍夠正常使用 jupload 謝謝。
已記錄

TMTZONG
FreeBSD 5.0 Release
Apache 2.0.47 | MySQL 3.23.54  | PHP Version 4.4.0
Plog 1.02 Beta
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #11 於: 十月 03, 2005, 07:42:00 下午 »

這是預設的設定,如過要更改有兩個地方要更改設定:

1. 全部站台管控 » 上傳設定 把 2000000 改為 10000000
2. 把 php.ini 中的 upload_max_filesize = 2M 改為 upload_max_filesize = 10M

這樣就可以把 上傳的限制從 2M 改為 10M。

Mark
已記錄

tmtzong
新手見習
*
文章: 7


檢視個人資料
« 回覆文章 #12 於: 十月 04, 2005, 09:14:09 上午 »

Hi Mark

依您的作法,修改後確有改善,向您說明測試結果:

在 plog1.01+jupload 會有問題(新增檔案就OK),
在 plog1.02 Beta+jupload 可以上傳,但.... 不管設定多少M(php.ini 、plog上傳設定),大概超過 7M,就失敗了(新增檔案狀況一樣)。

目前就這樣,這幾天會在UNIX下安裝 plog1.02 Beta ,再向您說明結果,謝謝您。
已記錄

TMTZONG
FreeBSD 5.0 Release
Apache 2.0.47 | MySQL 3.23.54  | PHP Version 4.4.0
Plog 1.02 Beta
markwu
系統管理員
超級會員
*****
文章: 3928


Mark Wu


檢視個人資料 個人網站
« 回覆文章 #13 於: 十月 04, 2005, 09:48:59 上午 »

因為你少改了一參數,PHP.ini 中的  post_max_size 也要改成 10M 才行。

這麼改不代表你能 upload 10M 的檔案上去,指代表所有傳到 server 的資料總和加起來最大為 10M

Mark
已記錄

FIEND
新手見習
*
文章: 40



檢視個人資料 個人網站
« 回覆文章 #14 於: 十月 04, 2005, 09:53:42 上午 »

不好意思 小弟補充一下說明 :

html 上也有個 post MAX_FILE_SIZE 的 限制 那個設定也要拿掉 之前寫一個專案調完php.ini 結果問題出在它身上



已記錄

我也來玩玩 blog 吧 ^^ 請大家多多指教

我就是不愛用 utf-8 的系統 -- plog big5 版本 漠漠進行中......

(十月九號要去日本玩啦 - 有事情找我的等我回國)

http://www.twbb.org
頁: [1] 2
LifeType 中文開發論壇  |  開發  |  外掛程式  |  外掛程式精華區  |  1.0.2 中 juploadNewResource 不能用? « 上篇主題 下篇主題 »
    前往: